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What are Symbols ?

§ Very often, a circuit (schematic) can be re-used.
§ Instead of copying everything, we can ‘include’ the 

schematic into another schematic
§ In order to identify the nets, we need a symbol

• This is a new view type

§ The nets which are passed to the outside world must be 
connected to pins in the schematic.
• For each pin in the schematic we also need a pin in the 

symbol.

§ Pins must have the same name as the connected net
§ They can be Input / Output / inputOutput (see later)
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Preparing the Schematic

§ The easiest way to create a symbol starts from a schematic
§ Using Create → Pin (Ctrl-P or button      ), create pins for all 

signals that should be visible ‘outside’
• outputs are signals that will drive to other cells
• inputs only receive signals. They must be connected later
• InputOutput are most general. Only use if you have to!

§ A pin labels the net, i.e. a further label is not required
§ Better remove all symbols used for simulation (sources..)
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Creating a Symbol from the Schematic

1. Select Create → Cellview → From Cellview
2. Check that ‘From View’ is schematic and ‘To view’ is symbol
3. Press ok. In the next window, select the pin locations
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Editing the Symbol

§ A symbol template is created:

§ You can set the origin under Edit → Origin
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This special label will 
later be replaced by 

the name of the 
master cell 

Green lines are only for optics, 
they have no function. You can 

add more such shapes in the 
Create → Shapes menu

A pin. Here: Input

The red BOX is the ‘selection 
box’. It is the region where you 

can later select the symbol.
(I prefer to keep it small…)

This special label will 
later be replaced by 

the name of the 
INSTANCE



Make Nice Symbols!

§ Your schematics get more readable if the symbols are 'nice':
• Power (if present at pins) may be grouped at the bottom
• Group bias signals, use 'good' names
• Inputs are left / outputs are right
• Digital signals are grouped
• Active Low signals have a bullet
• Clocks have a triangle
• Add a little drawing of the functionality

Create→Note→Shape or Create→Shape
• Add text: Create→Note→Text
• You may delete trivial labels
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Creating a Symbol from Scratch

§ You can also create an (empty) new symbol directly from 
the library browser with File → New → Cell View… with 
view type schematicSymbol

§ You must then place all pins, boxes, labels, .. by hand.
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Editing a Symbol

§ When you (later) add new pins to the schematic, you also
have to add them to the symbol.
• Make sure name and type are the same!
• Best copy other pins and rename them

§ You can move, 
stretch, … as usual

§ You can change the
size or 'justification' of
the labels
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@instanceName and @partName

§ Two special labels are created automatically:

• [@instanceName] will display – surprise! – the name of the 
instance (of this symbol) that you place in another schematic, 
i.e. I2 or, better, Iamp1 or so

• [@partName] displays the (library) name of the cell,
i.e. vorlesung_HighPass or NAND2

§ Place them somehow nicely (size / alignment / position)
VLSI Design: Schematics © P. Fischer, ZITI, Uni Heidelberg       Page9

do not 
confuse with 
@cellName



The Selection Box

§ When created automatically, a (red) Selection Box appears
§ It marks the area which will be used to 'highlight' / 'select' the 

instance (in the next hierarchy level):

• The Selection Box can be moved / resized
• If lost (or in manually created cells), it can be created by  Create 

→ Selection Box
• You cannot route over the Selection Box → keep it small
• If no Selection Box is defined, the maximal symbol size is used.

VLSI Design Exercise: Hierarchy Design © P. Fischer, ZITI, Uni Heidelberg       Page10

Selection Box 
in symbol

Highlighting in a 
schematic which uses 
an instance of the cell



Using the symbol

§ In a schematic, you can add your symbol now in the same 
way as any other instance
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PartName

InstanceName

Selection Box

InstanceName



Inputs / Outputs / InputsOutputs

§ After ‘Check & Save’, warnings may pop up in the CIW:

§ InputOutputs can be connected arbitrarily. Use with caution!
§ All schematics should be 'clean', i.e. issue no warnings!
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Shorted output pins
→ Warning ‘shorted output’

Unconnected inputs 
 → Warning ‘floating input’

Unconnected output
 → Warning ‘floating output’

If this missing connection is 
intended, connect the ‘noConn’ 

symbol from library ‘basic’



TRAVELING THE HIERARCHY



Traveling in the Hierarchy

§ Assume you are in Schematic A which contains an Instance 
of PartType B

§ If you want to modify (the symbol or schematic of) B, you 
normally have to open that cell from the library browser

§ You can better ‘dive into’ B by
• Selecting the instance
• Edit → Hierarchy → Descend Edit (Shift-X)
• Select the view
• Select if you want a new window / new tab / use existing tab

§ You then end up in symbol / schematic of B
§ When done, return back ‘up’ with Edit → Hierarchy → Return 

(Shift-B)

§ You can also Descend for Read Only (Ctrl-X) or Edit in Place 
(x). This Edits B but shows A ! Powerful but dangerous!
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GLOBAL NETS



Global Nets

§ A net is normally only known in the corresponding schematic
• Connecting nets between schematics requires pins

§ This can be tedious for signals which are used very often
• analogue / digital power / ground
• substrate potential

§ You can use global nets, known everywhere
• They are identified by an exclamation mark: xxx!

§ Common global nets are
• gnd! or sub! chip substrate
• gndd! and vddd! digital ground /supply 
• gnda! and vdda! analogue ground / supply

§ Handle them with care, because it is hard to track where 
they are used...
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Global Nets

§ There are several global 'symbols' in analogLib
• Under Sources → Global

§ They connect a net automatically to the corresponding 
global net

§ Therefore:
Connecting to symbol
'gnd' is the same as
labelling a net with 'gnd!'
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This net is 
selected



Pin Order

§ If can happen that the internal order of pins gets messed up
• You get a warning at Check & Save
• This happens if you copy pins from other cells, delete pins,..

§ To restore correct order, use
Edit → Properties → Pin Order

§ Best copy the Pin Order from 
another view:

§ In rare cases, you have to regenerate (for instance) the 
symbol. (There is a step which allows you to just 'repair' the 
wrong stuff so that you nice drawing is not affected)
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BUSSES AND ADVANCED NET NAMING



Advanced Net Names (Important!)

§ A single 'wire' on the schematic can represent several nets, 
i.e. it can be a 'bus' or bundle of nets.

§ Examples:
• Simple wire in
• Multiple wires a,b separated by comma
• Bus dá4:0ñ 5 signals: dá4ñ,…,dá0ñ
• Bus xá1:5ñ different index order: xá1ñ,…,xá5ñ
• Repetition á*3ña,á*2ñb this is equivalent to a,a,a,b,b
• Skip indices dá7:3:2ñ = dá7ñ,dá5ñ,dá3ñ
• Index list dá1:0,3,á*2ñ5ñ = dá1ñ,dá0ñ,dá3ñ,dá5ñ,dá5ñ
• Grouping á*2ñ(a,b) = a,b,a,b

§ This works for labels and for pins (but better only use busses!)

VLSI Design: Schematics © P. Fischer, ZITI, Uni Heidelberg       Page20

When a wire has multiple nets assigned:
Imagine the nets stacked onto each other in the order they are listed



More Complicated Examples

§ You often need a 'binary' encoding of signals:
• á*4ñ(a,b) =
á*4ñ(á*1ña, á*1ñb) = a,b,a,b,a,b,a,b

• á*2ñ(á*2ña, á*2ñb) = a,a,b,b,a,a,b,b
• á*1ñ(á*4ña, á*4ñb) = a,a,a,a,b,b,b,b
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Advanced Net Names

§ If you are not certain how a complicated net name expands:
Type the expression in the CIW (Command Interpreter 
Window) using

( dbProduceMemName "expression" )
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Multiple Symbols (Very Important!)

§ Instances can be indexed as well:
• An instance with name Má3:0ñ contains 4 elements Má3ñ…Má0ñ
• They are (again) lying ‘on top of each other’ (in the order given)

§ The instance pins are also stacked on top of each other
• A single pin of N instances becomes a bus which is N nets wide
• A pin with 2 nets (iná1:0ñ) becomes 2N nets wide etc.
• Connected nets must be have exact length OR

be a single wire (see net ‘sel’ below), connecting all nets
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Iná1:0ñ
sel

MUX
Iná1:0ñ

sel
out

Symbol

MUX
Iná7:0ñ

sel
Outá3:0ñ

Má3:0ñ
MUXá0ñ Outá0ñ

MUXá1ñ Outá1ñ

MUXá2ñ Outá2ñ

MUXá3ñ Outá3ñ

Outá3:0ñ

Iná7:6ñ

2 bit wide

8 bit wide

4 bit wide

1 bit wide

4 bit wide



Multiple Symbols: 2nd example

§ Here is a 3 Bit address decoder which activates one of 8 
output signals selá7:0ñ as a function of 3 address inputs 
addá2:0ñ:

§ Compact:
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add<0>

sel<0>

add<1>

add<2>

sel<1> sel<2> sel<7>

add<2:0> addB<2:0>
M_INV<2:0>

sel<7:0>

M_AND<7:0>
<*4>(<*1>add<0>,<*1>addB<0>)
<*2>(<*2>add<1>,<*2>addB<1>)
<*1>(<*4>add<2>,<*4>addB<2>)

This is: add<0>,addB<0>,add<0>,addB<0>,add<0>,addB<0>,add<0>,addB<0>



COMPONENTS WITH
(SYMBOLIC) PARAMETERS = DESIGN VARIABLES



Using Design Variables

§ The parameters of components can be assigned a text 
value. This shows up in the schematic netlist.

§ The design variable can
then be varied in
simulation

§ To preserve the value, you should
write back the design variable to the
schematic from the simulation window:

§ This is required for later LVS!!!! 
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§ When written back, the design variables are stored in the 
cell (not just in the schematic cell view) (thanks @ Michael!)

§ They can be seen and changed from the library browser in 
the cell properties:

§ (Later: Using Skill, search for property ‘designVarList’ from 
a schematic: (geGetEditCellView)~>cell~>prop    )

Design Variables
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SYMBOLS WITH PARAMETERS



Parameterized Symbols (Step 1/3)

§ It occurs that you need very similar schematics where only 
few parameters are changed (often transistor sizes)
• Example: Inverter with different PMOS widths
• (Unfortunately, parameters cannot be used everywhere…)

§ Instead of creating multiple cells, you can create one cell 
with a PARAMETER:

1. In the schematic:
introduce the parameter with pPar("pname") (capital P!)
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Parameterized Symbols (Step 2/3) – Optional!

2. In the symbol: Add a label
• Label Choice: analog device annotate
• Label Type: NLPLabel
Add any text, referring to the parameter as [@pname]
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Parameterized Symbols (Step 3/3)

3. Cadence still needs to know about the new parameter:
• In CIW→Tools→CDF→Edit
• Choose Scope: Cell
• Choose CDFLayer: Base
• Select Cell

• Add your pname in the form
• Type: String
• Set prompt string & default value
• Store Default: no (=default)
• Parse as CEL: yes
• Parse as Number: yes
• Editable Condition: t   (needed ?)
• Units: don't use (=default)
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Parameterized Symbols: Instantiation

VLSI Design: Schematics © P. Fischer, ZITI, Uni Heidelberg       Page32

§ The Symbol now shows your text + value
• You may need to delete

and re-instantiate
existing symbols..

§ You can now change
the parameter
in the instance properties



INHERITED NETS



Inherited Nets

§ It is possible to over-write nets in schematics (mostly 
supplies) from a higher hierarchy level.

§ This 'inherited nets' approach is not further described 
here…
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FEATURES OF THE SCHEMATIC EDITOR



Some Features

§ The additional display of net names at the pins of 
transistors is often confusing.
• You can turn this off under View → Hide Terminal Labels 

§ If you want to see all places where a net in one schematic 
connects:
• Enable Highlighting under View → Net Highlighting 

§ If you want to follow a signal through the hierarchy:
• Highlight the net under Create → Probe → Add Net
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